quarta-feira, 19 de março de 2008

Rodando Internet Explorer 7 no Linux


Nesta dica explico como instalar o IE7 da Microsoft no Linux, para isso é necessário instalar uma versão anterior, no caso IE 6. Baixe o script necessário para instalação do IE 6.0 no Linux.

Obs: Há a necessidade do wine instalado e configurado corretamente.

No shell (como root) faça a seguir:

# wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
# tar zxvf ies4linux-latest.tar.gz
# cd ies4linux-*
# ./ies4linux

Depois de instalado, baixe o IE 7 com o próprio navegador IE 6 que fora instalado, no caso da validação Windows Genuine, baixe o aplicativo em abrir... em vez de salvar como.., após a execução anote os códigos, digite-os no verificador e clique em validar, e pronto, faça download para uma pasta separada, após a conclusão do download faça extração com seguinte comando:

# wine IE7-WindowsXP-x86-enu.exe /x

Após a extração, copie as bibliotecas a seguir para a pasta ~/.ies4linux/ie6/drive_c/windows/system.

Bibliotecas: wininet.dll, iertutil.dll, shlwapi.dll, urlmon.dll, jscript.dll, vbscript.dll, mshtml.dll, mshtmled.dll, mshtmler.dll, advpack.dll, inetcpl.cpl.

Depois em dll-files.com, baixe normaliz.dll e dlldump.com, baixe inetcplc.dll e coloque-os na mesma pasta ~/.ies4linux/ie6/drive_c/windows/system.

No shell, ainda como root, execute:

# WINEPREFIX=~/.ies4linux/ie6 winecfg

Este comando seta IE6 padrão para o Windows XP.

Depois é só executar:

# ~/bin/ie6

Pronto, IE 7 executando, para mim é IE 6/7.

Fontes:
http://www.tatanka.com.br/ies4linux/page/Main_Page
http://www.leonardomiranda.com.br/dicas

Deixo claro que eu não recomendo o uso do IE7, porém sempre existem aqueles sites feitos por webmasters iniciantes que só funcionam no IE, ai sim pode ser uma opção.

Um abraço,
Wilton

4 comentários:

Gilberto Albino disse...

Olá caro, Wilton, de acordo com suas palavras:

"Deixo claro que eu não recomendo o uso do IE7, porém sempre existem aqueles sites feitos por webmasters iniciantes que só funcionam no IE, ai sim pode ser uma opção."

Em primeiro lugar, pelo fato de um software ser pago não implica que ele não deva ser usado ou menosprezado, certo? Eu creio que todos pagam pelas roupas que compram, então, não deveríamos andar vestidos?

E por segundo, eu trabalho com criação de sites há 8 anos e tenho grande experiencia com CSS no padrão tableless, e a questao de ter que usar navegadores IE nunca esteve em sites de "WEBMASTERS INICIANTES", e sim porque as engines que rodam o CSS nos navegadores se comportam diferente de nucleo para núcleo, e em algumas situações fica praticamente impossível se obter determido layout de forma unilateral em todos os navegadores, e isto se dá ao fator conhecido como 'haslayout'.

Ai vai um link sobre 'haslayout' explicando melhor o que estou dizendo.

http://www.maujor.com/tutorial/haslayout.php

Wilton Paulo da Silva disse...

Gilberto, concordo plenamente com o seu ponto de vista e sabendo a sua preocupação com o tema, e sabendo que você não é iniciante.

Porém, existem casos onde o Webmaster testa a aplicação em apenas 1 browser(IE) e sequer tem o trabalho verificar as funcionalidades nos navegadores concorrentes, como Opera, Firefox, Chrome....são desses casos que estou me referindo.

Abs.
Wilton Paulo.

Anônimo disse...

Otimo artigo, principalmente para quem precisa testar software web em diversas plataformas.

Anônimo disse...

Tive problemas ao instalar o ./ies4linux
apareceu esse erro?

-------------
O IEs4Linux 2 foi desenvolvido para usar as versões mais recentes do Wine (0.9.x). Parece que você está usando uma versão antiga (wine-1.1.9). Recomenda-se que você atualize seu Wine para a última versão (Vá para: winehq.com).

É preciso baixar o cabextract antes!
Baixe-o aqui: http://www.kyz.uklinux.net/cabextract.php
-----------------

alguma solução?

Postar um comentário

Gostou do artigo? Então deixe um comentário !!!